
 
 
 

 
 
 
 
 

Start a new ANSI Inch part 

● Click the Solid Edge applica�on bu�on in the top le� hand 
corner of the window.  

● Click on the “ New ” folder then select ANSI Inch Part.  
o If “ ANSI Inch Part ” template is not visible, select the “ Edit List ” bu�on at the top of the list. Then select 

“ ANSI Inch ” for the templates and click OK. 
 

Settings 

● On the Sketching tab and open the IntelliSketch op�ons. 
o On the Auto-Dimension tab place a check in  

“Automa�cally create dimensions for new geomtery”. 
o Select the the op�on for “Only when geometry is created with keyed-in values”. 
o Click OK to dismiss the IntelliSketch dialog.  

Create Front Panel 

● Under the “ Home”  tab, click on “ Rectangle by Center ”.  
● In the PathFinder on the le�, check the box next to Base Reference Planes to show  

the planes on the base coordinate system. 

● Hover the mouse over the “ Front”  plane (XZ plane) and click the lock icon or 
press F3 on the keyboard. 

● Click on the Front Face of the view cube in the bo�om right  
corner to change the view.  

● Place the cursor over origin point of the base coordinate where  
the red x axis and the blue z axis meet.  

o The endpoint glyph will appear and click to define the center of the rectangle.  
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● Drag the mouse to the side to see the rectangle.  
o Type “ 12 ” for the length. 
o Press tab and key-in “ 5 ” for the height. 
o Press tab and key-in “ 0 ” for the angle. 
o Press enter. 

● Click on the top right corner of the front face of view cube to switch to an  
isometric view. 

● Click anywhere inside the sketch and select one of the arrows to ini�ate an extrusion 
and move the mouse to the le� on the screen.  

o Type in “. 25 ” to create the thickness of the part. 
● Save the part as “ Bird House Back ”. 
● Select the Save As tab under the Applica�on bu�on menu and select the Save As 

command to save the file again as “ Bird House Front ”. 
● Under the drop down for rectangle by center, select “ Rectangle by 2 Points ” and lock 

onto the front face of the rectangle.  
o Press Ctrl + H to orient the view normal to the sketch plane.  

● Click on the bo�om edge of the face to ini�ate the rectangle.  
o Make the rectangle  3.000  wide,  4.000  high, and an angle of  0.000° . 

●  To locate the sketch from the edge of the part, locate “ Smart Dimension ” on the home 
tab click and select the le� line of the sketch and the le� edge of the part.  

o Place the dimensions and set to  1.500 in . 
● Press CTL+I to orient to an isometric view and click the region inside  

the newly created rectangle to display the drag arrows.  
o Click an arrow and drag the region through the part.  
o Click again to finish the cut. 

 

Copying features 

● Change the view to the front view.  
● Select the cutout feature in the PathFinder on the le� side of the screen.  

o Select the Mirror command and select the Z Axis (Right Plane) to mirror 
the cutout to the right side of the part.  

● Save the part and close the file. 
 
 
 
 
 
 
 
 
 
 
 

Crea�ng the Side Panels 

● Start a new ANSI Inch part. 
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● Using the rectangle by center command, lock onto the front plane and click on the origin 
of the base coordinate system.  

o Make the rectangle 7.00 in. square.  
o Use the line command to create 2 lines that start from the mid-point of the top 

line and reaches to each ver�cal line on the le� and right of the rectangle.  
o Add a Smart dimension by selec�ng on the angled line near the endpoint then 

select the bo�om horizontal line near the corresponding endpoint.  
▪ Click to place the dimension and key-in 5.00 for the distance. 

o On the Home tab, select the “Equal” Relate 
command and click on both angled lines.  

o Add a dimension from the top line to the bo�om 
line of the square.  

o Press the ESC key. 
● Press CTL+I and click on the center region that is in the 

shape of a pentagon.  
o Extrude this shape .25 in.  
o Click on the check mark next to sketches in the 

feature tree to hide the sketch.  
o Click the check box next to PMI in the feature 

tree to hide the dimensions. 

Adding Material Proper�es 

● In the PathFinder, double click on “Material (None)” to open up the  
materials proper�es dialog box. 

o Expand “Non-Metals” and then “Woods” to select “Wood, Pine”.  
o Click on “apply to model” to add the material proper�es to the part. 

Adding Color to Parts 

● Select the “View” tab at the top and select Part Painter in the style command bar. 

 
 
 

● Set the “Style” to Teal, set “Select” to face.  
● Click on the front face of the part. 
● Save the part “Bird House Side”. 
● Close the Part. 

 
 

Create Bo�om Panel 

Tutorial: Design a Bird House in Solid Edge Page 3 of 18 



 
 

● Start a new ANSI Part.  
● This �me, let’s use the Box command to create a box that is started on 

the Top plane (x,y Plane), centered on the coordinate system, and is  
11.5 in. wide, 7 in. tall and with a thickness of .25 in. 

● Add the “Pine” material property to the part, but this �me right mouse click on “Material (None)” and under 
recent materials, select “Wood, Pine” from the top of the list.  

● Save the part as “Bird House Bo�om”. 

Assembling the Bird House 

● Start a new ANSI Inch Assembly file. 
● On the le� side of the window, select the Parts Library tab.  

o Navigate to the loca�on where you have saved the Bird House parts.  
● Double click on “Bird House Bo�om”.  

o No�ce the bo�om panel is immediately placed at the center of the coordinate  
system; the part coordinate system is automa�cally aligned with the assembly  
coordinate system.  

● Now drag and drop the part “Bird House Side”.  
o The part is now ready to start rela�ng to the Bo�om part.  
o Select the bo�om edge face of the side panel and align to the  

bo�om face of the Bo�om panel.  
o Right mouse click to exit assembling the parts to see  

which face was painted Teal.  
● Once the painted side has been iden�fied, run the Assemble command. 

o Select the side opposite the teal side and mate to the short edge  
face of the Bo�om panel. 

● Next select the side edge face of the Side panel and align to the  
long edge face of the Bo�om panel. 

 
 
 
 
 
 

 

 

 

 
 
 
 

 

● Be sure the Teal side is facing outwards. 
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● Drag a copy of the Side panel from the PathFinder into the window  
and repeat the previous steps for the other side of the bird house.  

o The Teal faces should be poin�ng outward as shown. 
● Save the assembly as “Bird House” 

Adding the front and back panels 

● Open up the parts library and drag in “Bird House Front”.  
o Select the near face of the Front panel and select the long edge face of the Bo�om panel.  
o Ini�ally this will “Align” the faces.  

▪ Select the Flip bu�on to create a “Mate” between the parts.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Align the side edge face of the Front panel to the Teal side of the Side panel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

● Now align the bo�om edge face of the Front panel to the bo�om face of the Bo�om panel. 
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● Repeat the above step to achieve the same results for the back panel.  
● The assembly should look like the image on the right below. 

 
 
 
 
 
 
 
 
 
 
 

● Save the assembly. 

Edit parts in an assembly 

● To edit the Front panel, select the panel in the graphics window.  
o A small dialog box will appear with 2 icons.  

▪ Select the icon to “Edit in Place”.  

 
 
 
 

 

 

● Assign “Wood, Pine” material property to the part by right mouse clicking on “Material (None)” and selec�ng it 
from the top of the list. 

● Use Part Painter to apply “Teal” to the front and short sides of the Front panel. 
● Click the “Close and Return” bu�on to exit the part editor and return to the assembly. 
● Now do the same for the Back panel, making sure to paint the outside faces. 
● Save the assembly. 

 
 
 
 
 
 
 
 
 
 
 

Crea�ng Parts in the Assembly  

● On the Home tab select “Create Part In-Place”.  
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o Make sure the default op�ons are selected: 
▪ Ac�ve assembly loca�on 
▪ Coincident with assembly origin 
▪ Create component then edit in-place 

o Click OK to dismiss. 
● Make sure the template being used is set to “ansi Inch part.par” and set the material to “Wood, Pine” from the 

drop list.  
● Click the green check box and save the part as “Bird House Door”. 

 

● No�ce that Solid Edge immediately places you in the part mode because of the op�on to  
“create and edit in-place” was selected.  

● Select “Project to Sketch” command on the home tab. 
o Hold down the Shi� key to enable selec�ng faces from  

background parts. 
o Select the Front face of the Front panel and select the  

lock icon to lock onto that plane.  
o Accept the default Project to Sketch Op�ons and 

dismiss the dialog box. 
 
 

 

 

 

 

 
 

● Select all 4 edges of the le� cutout in the Front panel to  
project onto the plane.  

o Note lower edge is projected from  
the Bo�om panel. 
 
 
 
 
 
 
 

● Now a region has been created that can be extruded to  
create the door, but first, let’s add two circles. 

o Select the “Circle by Center Point” command and  
key-in 1.5 in. for the diameter. 
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o Touch the top sketch edge with the cursor to highlight the  
midpoint and drag the circle straight down to establish  
a ver�cal rela�onship to the midpoint.  

▪ Click to place. 
o Add a Smart dimension from the bo�om edge to the  

center of the circle. 
▪ Click to place the dimension and key-in 2.5 in. to  

locate the circle ver�cally. 
o Using the same method, add a .25 in. Diameter circle  

centered horizontally and 1 in. from the bo�om  
edge.  

 

 

 

 

 

 

 

● Press CTL+I.  
● Click the region outside of the large circle and in the QuickBar change the extent type to “From-To”.  
● Select the long edge face of the Bo�om panel (visible in the other cutout) as shown for the “To” face. 

 
 
 
 
 
 
 

 

 
 
 
 
 
 

 

● Using Part Pinter, paint the front face “White”. 
● Save the part then click the red “X” labelled “Close and Return”.  
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Relate the door to the assembly and add second door  

● Even though part was created in-place, the part is not constrained to the assembly.  
● Click on the door then select the “Assemble” command.  

o Align the front face of the Door to the near face of the Front panel. 
o Mate the top thickness face of the Door to the top thickness face of the opening in the Front panel. 

▪ Hover the mouse and right click; Quick Pick will likely be needed to select the correct face.  
o  Mate the side thickness face of the Door to the side thickness face of the opening in the Front panel. 

▪ Hover the mouse and right click; Quick Pick will likely be needed to select the correct face.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Now that the first door has been added to the assembly, the assembly rela�onships can be  
captured to make placing the second instance of the door easier.  

o Select the first door and run the Capture Fit command.  
o Accept the rela�onships by clicking OK on the dialog. 

● From the Pathfinder, drag a copy of the Door into the graphics  
window. 

o No�ce the first face highlights on the new door and  
all that is required is to select the corresponding faces  
on the Front panel. 
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● Save the assembly. 

Create wall divider 

● Use Create Part In-Place to define a new ansi inch part using the default op�ons and assign Wood, Pine. Save the 
part as “Bird House Center”.  
 
 
 
 

● In the PathFinder, display the part reference planes by clicking on the box  
next to Base Reference Planes.  

● Hide the first instance of the Side panel by unchecking it in the  
Assembly PathFinder.  
 
 

● Select the “Project to Sketch” command and select the Right (yz) plane.  
o Accept the default Project to sketch op�ons.  
o Change the view to the right side using the view cube.  
o Select the angled top edges and side edges of the Side panel,  

and the top edge of the Bo�om panel. 
 
 
 
 
 

● Press CTL+I to transi�on to an isometric view 
● Click on the region inside the sketch and select the arrow to begin  

the extrusion.  
o Change the extrusion type from “From-To” to “Finite”. 
o Select the symmetric bu�on to the right of the extend type.  
o Extrude the part .25 in.  

● Close and return back to the assembly.  
● Show the side panel again. 
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Create metal roof 

● Run the Create Part In-Place command and accept the default se�ngs. 
o Change the template to “Ansi Inch Sheet Metal.psm”.  
o Set the material to Galvanized Steel 

 
 
 

o Accept and save the sheet metal part as “Bird House Roof”.  
● Using the Rectangle by Center command, press and  

hold the shi� key down while hovering over the angled  
edge face of the Center panel.. 

o When the F3 lock icon appears, press 
F3 to lock to that plane.  
 
 
 
 
 
 
 
 

● Press Ctrl+H on the keyboard to make the sketching view go normal to the locked on plane.  
● Make the width of the rectangle 5 in. and the height 12.50 in. on the QuickBar.  

 
 
 
 

● Move the rectangle to the center of the coordinate system and align to the Y axis.  
o Click to place the rectangle and set the angle to 0.00° 
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● On the Tools Tab, enable Peers edge locate. 
 
 
 

● On the Home tab, using the Connect rela�onship to connect the  
midpoint of the upper horizontal sketch line to the midpoint of the  
upper thickness edge of the Center panel as shown: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

● Press CTRL+I to return to the isometric view 
● Select the region and extend the sheet metal material  

thickness away from the assembly.  
 

 
 
 

● Click the top edge (at the peak) of the sheet metal part and select the short arrow that is  
poin�ng perpendicular to the selected face to add a flange.  

o Change the material side to “Material Outside” in the QuickBar. 
 
 
 
 
 
 

o Make the length 5.00 in. 
o NOTE the default 90° angle is not correct. 

●  From the Face Relate group on the Home tab, select the Coplanar rela�onship. 
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o Select the  bo�om  face of the roof flange and accept with a right click or  
green checkmark. 

o Select the top edge of the side panel to align with.  
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

● Save the part and return to the assembly. 
o You will no�ce interference with the Front and Back panel which we will address later. 

 
 
 
 
 
 
 

● Click on the roof and select “Assemble” on the home tab.  
● Select the underside face on the roof tab to mate to top angled edge face  

of the Side panel.  
●  Repeat to mate the bo�om face of the Roof flange to the other angled face  

of the Side panel.  
 
 
 
 
 
 
 
 
 
 
 

● Set the offset distance of the Flashfit alignment rela�onship to -0.25in.  
o Select the end thickness face of the Roof first to create an offset alignment to outside Teal face of the  

Side panel. 
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Fixing the Front and Rear Wall with the Roof 

● No�ce that the edge of the front and rear walls are protruding out of the roof.  
● To fix this issue we will use the same Coplanar relate command that we used to change the angle of the Roof 

flange. 
● Click on Bird House Front.  

o Select the icon on the right on the menu to edit the part.  
 
 

● On the Home tab, run the “Coplanar” command from the face relate sec�on. 
o Select the top edge face of Front panel and right click or press enter to accept.  
o Select the underside face of the roof as he target. 
o Close and return to the assembly. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Click on Bird House Back.  
o Select the icon on the right on the menu to edit the part. 
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● On the Home tab, run the “Coplanar” command from the face relate sec�on. 
o Disable the symmetric Design Intent by clicking “S” or unchecking Symmetry in the dialog. 

▪ This will prevent the bo�om edge of the panel moving symmetrically when the  
top edge is angled. 

o Select the top edge face of Back panel and right click or press enter to accept.  
o Select the underside face of the roof as he target. 
o Close and return to the assembly. 

 
 
 
 
 
 
 
 
 
 

 

● Return to the assembly and save the assembly. 
 

 
 
 
 
 

Create Bird Dowel Rod 

● Create a new part in-place using the “ansi inch part.par” template and the default op�ons. 
o Set the material to Wood, Pine  

 
 
Save the part as “Bird House Dowel Rod”. 
 

● Select the Cylinder command under the Box command pull-down  
menu on the Home tab. 

o While pressing and holding the Shi� key, move your cursor  
to the inside edge of the Hole in the Door panel to select  
the INSIDE face to lock to. 
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o Find the center of the small circle in the Door to locate the center of the cylinder and click. 
o Set the diameter by loca�ng the edge of the hole in the Door or by keying in .250 in. diameter. 
o Extend the cylinder 2.75 in. to the outside of the assembly.  

▪  Note: If the extrusion is extending symmetrically, press the “shi�” key to symmetry off. 
 
 
 
 
 
 
 
 
 
 
 
 
 

● Use part painter to paint the en�re Body “Teal”. 
 
 
 

● Close and return to the assembly.  
● Select the Dowel part and pick “Assemble” on the home tab.  

o Click the cylindrical sha� of the dowel to align with  
the bo�om hole on the Door panel. 
 
 
 
 
 
 
 
 
 

o Change the rela�onship type to Planar Align in the Assemble QuickBar. 
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o Select the end face of the Dowel shown and align to the inside face of the Door panel. 
▪ HINT: Hovering the cursor over the inside circular edge of the large hole in the Door makes it 

easier to select the inside face. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 

● Now that the first Dowel has been added to the assembly, the assembly rela�onships can be  
captured to make placing the second instance of the Dowel easier.  

o Select the first Dowel and run the Capture Fit command.  
o Accept the rela�onships by clicking OK on the dialog. 

● From the Pathfinder, drag a copy of the Dowel from PathFinder  
into the graphics window. 

o No�ce the cylindrical face highlights on the new Dowel and all that is required is to select the 
corresponding hole in the other Door panel.  

o Select the inside face of the other Door as the target for the planar alignment. 
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● Save the assembly. 
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